现在的位置: 首页 > Linux > 正文

Linux下好用的版本控制处理冲突 文件对比工具Meld

2015年10月16日 Linux ⁄ 共 445字 ⁄ 字号 暂无评论

由于最近公司用的git版本控制器,以前在上家公司用的是svn,自带有文件对比,以前也就没有了解文件对比方免得软件工具,现在公司改用git,又是在Ubuntu下开发项目,刚开始解决冲突用的编辑器直接看,眼花缭乱的,然后就随便百度了下,用了几款工具都不理想,最终发现了这款小工具,个人觉得还不错,推荐个大家,下面是meld的安装配置,

1 安装

$ sudo apt-get install git

首先安装git 当然这里是针对还没有装git的情况下

2 配置 meld

$ sudo apt-get install meld

$ vim ~/git-meld.sh

#!/bin/sh

meld $2 $5

$chmod 777 ~/git-meld.sh

#vi .gitconfig

[merge]

tool = meld

使用Meld代替你的版本控制系统(可选)

$git config --global diff.external ~/git-meld.sh

配置成冲突处理工具

$git config --global merge.tool ~/git-meld.sh

给我留言

您必须 [ 登录 ] 才能发表留言!